Subject: [PATCH bazel-zig-cc 0/1] Fix include root path for macos-aarch64

From: ~kmicklas <[email-masked]>
Date: Thu, 15 Sep 2022 14:40:41 +0000

Despite the odd inconsistency between OS/arch, the others appear correct
from a latest nightly.

Ken Micklas (1):
  Fix include root path for macos-aarch64

 toolchain/defs.bzl | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

-- 
2.34.4

---

From: ~kmicklas <[email-masked]>
Date: Thu, 15 Sep 2022 15:37:35 +0100

From: Ken Micklas <[email-masked]>

---

diff --git a/toolchain/defs.bzl b/toolchain/defs.bzl
index 71214f6..f72412d 100644
--- a/toolchain/defs.bzl
+++ b/toolchain/defs.bzl
@@ -70,7 +70,7 @@ def toolchains(
         host_platform_include_root = {
             "linux-aarch64": "lib/zig/",
             "linux-x86_64": "lib/",
-            "macos-aarch64": "lib/zig/",
+            "macos-aarch64": "lib/",
             "macos-x86_64": "lib/zig/",
             "windows-x86_64": "lib/",
         },
-- 
2.34.4

---

From: "builds.sr.ht" <[email-masked]>
Date: Thu, 15 Sep 2022 14:58:28 +0000

bazel-zig-cc/patches/.build.yml: SUCCESS in 17m45s

[Fix include root path for macos-aarch64][0] from [~kmicklas][1]

[0]: https://lists.sr.ht/~motiejus/bazel-zig-cc/patches/35334
[1]: mailto:[email-masked]

✓ #845320 SUCCESS bazel-zig-cc/patches/.build.yml https://builds.sr.ht/~motiejus/job/845320

---

From: Motiejus Jakštys <[email-masked]>
Date: Thu, 15 Sep 2022 22:23:41 +0300

>  1 file changed, 1 insertion(+), 1 deletion(-)

Thanks, applied. Though those will likely need to be revised soon -- I
remember reading somewhere that those prefixes will be made consistent
at some point. It's either landed, or there is an open PR.

Motiejus