Subject: Re: [PATCH bazel-zig-cc 1/1] zig launcher: replace shell wrappers with a binary

From: Philippe Voinov <[email-masked]>
Date: Fri, 30 Dec 2022 19:54:59 +0100

I ran into problems with missing shell utilities (dirname and sed)
when using bazel-zig-cc with rules_rust. rustc seems to unset PATH
when calling tools like the linker, which causes problems with the zig
tool wrapper scripts. I guess this patch would solve the issues that
I'm seeing?

---

From: Motiejus Jakštys <[email-masked]>
Date: Fri, 30 Dec 2022 21:07:55 +0200

> tool wrapper scripts. I guess this patch would solve the issues that

Hi Philippe,

It has a high chance to work, but you never know until you try. Feel
free to test the patch yourself (or the remote branch
motiejus_launcher_zig[1]) and please report back.

I am hesitant to merge it as-is without Fabian's ack whether it works
on Windows though.

[1]: https://git.sr.ht/~motiejus/bazel-zig-cc/tree/motiejus_launcher_zig